[Support request] Ajax Pagination

Please login to receive premium support.

Support for the free plugin can be found here.

Home Forums Pro Support Ajax Pagination

  • This topic has 3 replies, 2 voices, and was last updated 1 year ago by Tom.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #11874
    Sarah
    Participant

    I am running into an issue with the pagination. I know it is said that that it doesn’t work if there are more than one list on the page. Is there any way around that? The regular pagination works just fine for that list. And it would be a fine option, it just doesn’t look good when you click next page, and then it reloads the page and sends you back to the top. Would like for the next content to load where the actual section it.

    Thanks in advance!

    Sarah

    #11877
    Tom
    Keymaster

    Hi Sarah,

    Any kind of pagination will likely cause issues if there are multiple lists on a page. If the regular pagination is working, the AJAX pagination might – have you tried it? If so, what’s going wrong?

    Let me know 🙂

    #11883
    Sarah
    Participant

    Hi Tom! Thanks so much for the reply. I did try it. Basically what I have is a tabbed section, each tab has a different list in it. It works normally switching between tabs, but when the tab is set to All, that is when the pagination shows up. If you click view more, it loads some of the lists more than once and then when you switch to the other tabs, the lists are no longer accurate. I am not sure if that makes sense or not. Here is the staging link. If you navigate through the tabs, you’ll see it working fine. and then if you go back to all and press View More, you’ll see duplicate projects and then if you navigate back through the tabs you’ll see them not showing correctly.
    http://hoalahi.flywheelstaging.com/about/#projects

    Thanks!

    #11935
    Tom
    Keymaster

    Hi there,

    Pagination itself is problematic when there are multiple queries on a page, unfortunately. I’m not sure there’s an easy fix available.

    I can take a look, but your staging link requires a user/pass.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.