[Resolved] Cards with Elementor

Please login to receive premium support.

Support for the free plugin can be found here.

Home Forums Pro Support Cards with Elementor

Tagged: ,

This topic contains 21 replies, has 2 voices, and was last updated by  Bernhard 21 hours, 36 minutes ago.

Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • #11126

    Bernhard
    Participant

    Hi Tom,
    after having defined the cards layout, I’m trying to create my new landing page.
    The problem I encountered is that Elementor shows polaroid in 2 columns. It is below the button “Praktische Tipps”.
    Furthermore, the excerpt is defined with 15 words but it is showing more and the “read more” (->) defined in the function file does not show up.
    Can you please help to solve this.

    #11128

    Bernhard
    Participant

    OK, I found one problem. It was, that in “columns” of WPSP 2 columns were defined. This did not happend with the Classic Editor.
    But the “read more”, which I defined in the functions.php, is missing in categories. It is there when I define pages.

    • This reply was modified 1 month ago by  Bernhard.
    #11142

    Bernhard
    Participant

    Hi,
    Can you please check the problem I have with the categories. As I’ve reported, cards with categories show more than the 15 words defined in the excerpt and the “read more” (->) defined in functions.php is not displayed.

    It works correctly with posts and pages. Testpage

    Then I have two more things:
    On image hover, the post/page title is shown. How can I disable this. (eg Rom Ciam-pino Flug-hafen-transfer …- I need these breaks ­ for better legibility)
    In polaroid, I want to reduce the padding between title and text, how can I do this.

    #11143

    Bernhard
    Participant

    Once more, sorry. I found the problem in categories, it depends on the <!--more-->. How can I trigger this in a way, that in WPSP it shows only the number of words defined in Excerpt length?
    The other two things are the post/page title shown on image hover and the padding between title and text in polaroid.

    #11187

    Tom
    Keymaster

    Hi there,

    You can tell WPSP to ignore the more tag like this:

    add_filter( 'wpsp_more_tag', '__return_empty_string' );

    For the image title, try this:

    add_filter( 'wpsp_image_title', '__return_empty_string' );

    Lastly, try this for the padding:

    .wpsp-polaroid .wp-show-posts-entry-header {
        margin-bottom: 0;
    }

    Let me know 🙂

    #11188

    Bernhard
    Participant

    Hi Tom,
    here the results:

    Ignore the more tag: ok

    Hide post/page title on image hover: works only, when an image overlay icon is defined. Would it be possible to define a “blank” icon with which I can trigger where to show the title and where not?

    Padding: the padding between title and text is reduced now but still too much. How can I reduce the padding above the text?

    Thank you 🙂

    #11223

    Tom
    Keymaster

    I’m no longer seeing the title tag. It shouldn’t matter whether the overlay icon is defined or not. Can you remove it for now so I can see the title displaying?

    What about this?:

    .wpsp-polaroid .wp-show-posts-entry-title {
        min-height: auto;
        margin-bottom: 5px;
    }
    #11227

    Bernhard
    Participant

    Hi Tom,
    I added a line height like this, otherwise the underscores were cut:

    .wpsp-polaroid .wp-show-posts-entry-title {
        line-height: 1.2em;
        min-height: auto;
        margin-bottom: 10px
    };

    So this is ok. Thank you.

    I removed the image overlay icon from “polaroid with pages” and now you will see the title tag.

    I added the image overlay icon to “polaroid with categories” and there you will not see the title tag.

    #11248

    Tom
    Keymaster

    Weird, looking at the code, it really shouldn’t matter.

    Maybe try this?:

    add_action( 'wp', function() {
        add_filter( 'wpsp_image_title', '__return_false' );
    } );
    #11264

    Bernhard
    Participant

    Hi Tom,
    the result is the same as with
    add_filter( 'wpsp_image_title', '__return_empty_string' );
    => Title is hidden when image overlay icon is defined.

    Above are two cards without overlay (and title), below two cards with overlay (and without title).
    I think it would be good to have an empty (transparent) icon.

    #11275

    Tom
    Keymaster

    I just tested this:

    add_filter( 'wpsp_image_title', '__return_empty_string' );

    It works regardless of whether the overlay icon is active or not. I wonder if you have caching on the site preventing it from working?

    #11276

    Bernhard
    Participant

    I do not know why. I’ve inserted
    add_filter( 'wpsp_image_title', '__return_empty_string' );
    again and flushed the cache of the site and the browser, but on my test page the title is shown if no overlay icon is set.

    #11294

    Tom
    Keymaster

    Do you have a conflicting function, maybe? Maybe the same filter used elsewhere?

    #11303

    Bernhard
    Participant

    Referring to WPSP, I have the following functions

    // Read more function in WPSP
    add_filter( 'wpsp_ellipses', function() {
        return sprintf( 
            '...<a href="%1$s">&ensp;<strong>-></strong></a>',
            get_permalink()
        );
    } );
    
    //Disable read more tag in wpsp
    add_filter( 'wpsp_more_tag', '__return_empty_string' );
    
    //Disable image title on hover in wpsp
    add_filter( 'wpsp_image_title', '__return_empty_string' );

    I’ve tested with Elementor and without, but it is the same thing. Would it help if you look directly into the site?

    #11313

    Tom
    Keymaster

    Do you have another site you can test on so we can know for sure whether it’s specific to this site or not?

Viewing 15 posts - 1 through 15 (of 22 total)

You must be logged in to reply to this topic.