[Support request] Display "Ream More" at the end of the post excerpt

Please login to receive premium support.

Support for the free plugin can be found here.

Home Forums Pro Support Display "Ream More" at the end of the post excerpt

Tagged: 

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #6846
    Clayton
    Participant

    Hey guys,

    I’m trying to get this look on the “Ream More” section. Basically displaying it inline with the excerpt. Any help would be great. Thanks!

    Screenshot: https://imgur.com/a/sAZK4Ce

    #6851
    Jonathan
    Participant

    I figured out how to get it working. See my post: https://wpshowposts.com/support/topic/read-more-link-inline/

    #6853
    Tom
    Keymaster
    #8165
    Clayton
    Participant

    Hey guys,

    I was never able to get this working properly. I have the beta version installed and activated. Is this option built in to the beta version?

    #8170
    Jonathan
    Participant

    Hi Clayton,

    If you download the plugin from here you will be able to fix the problem:
    https://github.com/jeiseman/wp-show-posts

    After using this version of the plugin, I put the following in my functions.php:

    add_filter('wpsp_content_more_link', function() {
        return null;
    } );
    add_filter( 'the_content_more_link', 'generate_custom_content_more', 16 );
    function generate_custom_content_more( $more ) {
        return ' <a class="read-more content-read-more" href="'. get_permalink( get_the_ID() ) . '">' . __('[continued...]', 'generate') . '</a>';
    }

    Jon

    #8173
    Tom
    Keymaster

    That change will be live in the next version of WPSP as well: https://github.com/tomusborne/wp-show-posts/commit/4423b76a05fb5ffddba2a1a9748756c1c927f7dd

    #8174
    Clayton
    Participant

    Hey Jon,

    Thanks for the reply. There must be some sort of conflict with something. I’ve tried with your version of the plugin and added the filters to my functions but it still doesn’t return anything. Not sure what I’m missing!

    Clayton

    #8180
    Jonathan
    Participant

    Hi Clayton,

    You might have some other plugin (or in your own functions.php) that is calling add_filter on the ‘the_content_more_link”. Try changing the priority in the add_filter call to be a larger number (say 99 instead of 16) and see if this solves the problem.

    Also, make sure you’re using my version of the plugin. Look at 474 of wp-show-posts.php and make sure it looks like this:

    <?php
    	$content_more_link = apply_filters('wpsp_content_more_link', false, $settings );
            the_content($content_more_link);
    ?>

    Jon

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.