[Support request] Empty WPSP Pages Getting Indexed By Google

Please login to receive premium support.

Support for the free plugin can be found here.

Home Forums Pro Support Empty WPSP Pages Getting Indexed By Google

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #27191
    joe
    Participant

    Hello,

    I’ve contacted support via email as I didn’t want to alarm other users about this issue, as it may be an isolated case with my site. But for the past weeks, Google has been indexing empty WPSP pages on my site. I contacted support and the person whom I talked to just said that I this is outside of the scope of the plugin’s support and that I could go to this page: https://www.cloudaccess.net/wordpress-tutorials/163-maintenance/1184-disabling-search-engine-indexing-for-wordpress-2.html# that page teaches how to deindex the whole site. I don’t even… Anyways..

    When I do a site:domain.com on google, and I adjust the time frame to this month, I can see hundreds of pages like domain.com/wp-admin/admin-ajax.php?action=wpsp_pro_process_simple_like&post_id=1130&nonce=0f1d32c1ad&disabled=true being indexed, and everyday I am getting more and more pages like this indexed by Google. The thing is, I haven’t updated the plugins, WP and GP since last year. All I did during this time is to just add more and more content and then this suddenly happened without me changing anything in the site.

    You can see the “wpsp_pro_process_simple_like” in the URL that is being indexed. That is why I approached WPSP support. Since WPSP = WP Show Post, right?

    I already sent screenshots and still haven’t gotten a response aside from the initial reply. That was 4 days ago. And since then dozens and dozens of this pages has been indexed. I already saw 300+ pages appearing as a warning in Google Search Console. Everything is dmin-ajax.php?action=wpsp_pro_process_simple_like&post_id kinds of links in GSC warning.

    What I did since 4 days ago:

    – I went to SEO Framework plugin settings and enabled the “Advanced Query Protection” it says there: Some URL queries can cause WordPress to show faux archives. When search engines spot these, they will crawl and index them, which may cause a drop in ranking. Advanced query protection will prevent robots from indexing these archives.

    – Added the second disallow in robots.txt so it looks like this now:
    User-agent: *
    Disallow: /wp-admin/
    Disallow: /wp-admin/admin-ajax.php?*

    – Updated GP, WP and all of the plugins

    We all know that these kinds of empty pages can get the site penalized by Google and everyday, more and more pages like these on my site are suddenly being indexed. If this is not an issue with WPSP, then please tell me why the links contain wpsp_pro_process_simple_like so I could check and find out the root of the problem. No other back-end pages are being indexed, it’s just hundreds of blank page /wp-admin/admin-ajax.php?action=wpsp_pro_process_simple_like&post links with different post ID.

    Since I’ve become a customer of GP and WPSP, I’ve praised and recommended the product to the IM forums that I am a member of especially to newbies and to the people that I come across IRL who wants to build a website. Tom and the team has never left me hanging when I have an issue with the site. But come on, I’ve been waiting for 4 days for a proper response.

    #27204
    elvin
    Moderator

    Hi there,

    I’ve contacted support via email as I didn’t want to alarm other users about this issue, as it may be an isolated case with my site. But for the past weeks, Google has been indexing empty WPSP pages on my site. I contacted support and the person whom I talked to just said that I this is outside of the scope of the plugin’s support and that I could go to this page: https://www.cloudaccess.net/wordpress-tutorials/163-maintenance/1184-disabling-search-engine-indexing-for-wordpress-2.html# that page teaches how to deindex the whole site. I don’t even… Anyways..

    Yes, I believe that was my reply last February 19 on your mail but it didn’t get any additional reply about this so the email ticket was kept closed. (it automatically opens back up when users send a reply)

    I offer my sincere apology for the frustration it caused. Perhaps you actually tried to send a reply back but we didn’t get any from our end.

    And as mentioned previously, this isn’t actually within the scope of the plugin as this is best done with a SEO plugin(I believe Yoast can do this) or theme and possibly its premium addon if it allows for display rule hooks (GP Premium has this, see Hook elements).

    But to help you out, if you specifically want to prevent a specific page from being indexed, find a plugin that allows for conditional hooks(like GP Premium’s hook element) and try hooking this to the page’s header of the page with the empty WPSP.

    <meta name="robots" content="noindex">

    • This reply was modified 1 week, 2 days ago by elvin.
    • This reply was modified 1 week, 2 days ago by elvin.
    #27208
    joe
    Participant

    Hello, I did send a response to the email directly, but I understand that these sort of things happen.

    Yes, I am already using GP Pro and WPSP Pro. But the pages being indexed are /wp-admin/admin-ajax.php?action=wpsp_pro_process_simple_like, I don’t think that I can add noindex to those pages as it is not an actual content page. Besides, I already had this in my robots.txt from the very start:

    User-agent: *
    Disallow: /wp-admin/

    4 days ago, I then added the:
    Disallow: /wp-admin/admin-ajax.php?*

    It’s not an option for me to switch to Yoast. SEO Framework is a much better plugin for my operations. I already enabled the “Advanced Query Protection” in SEO Framework plugin 4 days ago. But it is still indexing the back-end pages. There are no other back-end pages being indexed. I just have hundreds of /wp-admin/admin-ajax.php?action=wpsp_pro_process_simple_like pages being indexed. And when I click those links, it is just a blank page.

    #27244
    Tom
    Keymaster

    Hi there,

    Adding the following should prevent these links from being followed/indexed:

    Disallow: /wp-admin/admin-ajax.php?*

    Have you requested that the URLs be removed? Are you sure they’re continuing to get indexed since adding that line to your robots.txt?

    #27246
    joe
    Participant

    Hello,

    I just checked it now using site:domain.com with time range set to “past 24 hours” and there have been 14 new indexed pages like this. I can request it to be removed but I have 3,000+ articles and the way it is going is that it is indexing these kinds of pages randomly and not by the date it is posted. Some indexed pages contains a post ID that has been published many months ago.

    I cleared the cache and restarted the server applications in Cloudways 4 days ago right after adding that line to robotx.txt. I will keep on monitoring site:domain.com everyday.

    #27366
    Tom
    Keymaster

    Strange – Google should be respecting your robots.txt.

    If it’s causing a big issue like this, the safest thing you can do is turn off the “Like” option in your lists – that will prevent it right at the root. Not ideal, as it’s a cool feature, but it may be a good solution until Google clears the indexed URLs.

    #27440
    joe
    Participant

    In the last 24 hours 30 more pages like this was indexed. What do you think is the cause of this? AFAIK, my other sites that also uses WPSP pro are not indexing these pages. And I’m using GP in all of them. The only thing that makes this site different from my other sites is that I use Permalink Manager Lite plugin to force all of my public content URL to not have the ‘/’ at the very end of the URLs. It 301 redirects it automatically to non ‘/’ version as soon as I publish.

    I agree, I like this feature. I enjoy seeing the counter increase especially in the buried pages, it lets me know people are actually getting there. But I’m gonna try what you said. If there really is no other way.

    #27516
    Tom
    Keymaster

    Definitely strange, especially as it isn’t happening on your other sites.

    I wonder where the search engines are even finding those links – they aren’t directly accessible from the plugin. It’s the AJAX action that’s initiated once the heart is clicked.

    One last thing that comes to mind – we could try adding rel="noindex nofollow" to the link. It would involve manually changing the plugin file, but I’m happy to provide instructions on doing that if you’d like to give it a try.

    Let me know 🙂

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.