[Support request] excerpt cap not applied on manual excerpts

Please login to receive premium support.

Support for the free plugin can be found here.

Home Forums Pro Support excerpt cap not applied on manual excerpts

Tagged: 

This topic contains 12 replies, has 2 voices, and was last updated by  drew 6 months, 2 weeks ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #2955

    drew
    Participant

    FYI, I originally tagged this on at the end of this thread but I think it may not have shown up on your radar: https://wpshowposts.com/support/topic/some-suggestions-you-might-already-have-solutions-for/#post-2947. Here’s the original message:

    I’m experiencing a similar issue here in that the word limit is not being applied to custom excerpts entered. I’m using Visual Composer (VC) layouts on post pages so if I don’t use custom excerpts, WPSP pulls all the VC shortcode stuff before the actual content.

    I tried following the above tips but got lost at the final stage via “Add as a code snippet and set a custom field on your post page with the name ‘wpsp_excerpt’ and the value as your custom excerpt and it will display for WP Show Posts.”

    There is nothing in the name dropdown labeled ‘wpsp_excerpt’ and I’m unclear on what the actual value should be.

    Is there an easier way to go about this?

    #2972

    Tom
    Keymaster

    Hi Drew,

    Just answered that other topic, but will reply here as well in case others have the same question.

    The Custom Fields meta box allows you to add new names to the list, so click “Enter New” and name it wpsp_excerpt.

    Then the value of that name would be the excerpt text you want to use.

    Hope this helps 🙂

    #2976

    drew
    Participant

    I think I get it, so it this would mean having to manually move all existing custom excerpts over as a custom field, correct?

    That does seem alike a tremendous amount of work, not to mention needing to remember to do it for each new post as well.

    Assuming I’m processing everything correctly, is there a way to automate this so it uses the native WP excerpt?

    #2977

    drew
    Participant

    And as a quick follow up, even after applying the custom field, I still don’t believe the excerpt cap is being applied. Here’s the snippet: https://www.screencast.com/t/rgweiFJLwXh6

    And here is the custom field: https://www.screencast.com/t/xnKNQPY25C6

    #2981

    Tom
    Keymaster

    Ah, I understand. So you’ve set a word limit in the WPSP settings, but it doesn’t work when you use the standard Excerpt meta box?

    If so, that sounds like a bug. I’ll take a look!

    #2983

    drew
    Participant

    Correct, my apologies for not being clear. But to confirm, the SPSP word limit setting is not being applied to the standard Excerpt box.

    I was using that instead of the auto-excerpts becasue the Visual Composer shortcodes were getting pulled (although that part was entirely expected behavior).

    I do have this install up and running on a live environment if that helps: https://ventureindustriesonline.com/all-add-ons. Each of those excerpts should only be displaying 72 words. It’s also worth pointing out that I did update this install to WP 4.9.

    #3041

    drew
    Participant

    Hi Tom, just checking back in on this one following the holiday.

    #3048

    Tom
    Keymaster

    This is indeed a bug – I’ll get it fixed in the next version.

    I’ll update this thread when I have the updated code so you can try it out.

    #3052

    drew
    Participant

    Many thanks!

    #3143

    drew
    Participant

    Hi Tom, just checking in on this one in the wake of the 2.0 theme release.

    #3161

    drew
    Participant

    Bump. Just checking in again on this one. Anything new?

    #3202

    Tom
    Keymaster

    Playing with this now. By default in WordPress, using the custom excerpt metabox will ignore the excerpt length set. I’m not sure there’s any way around it I’m afraid. I’ll play with it some more.

    #3219

    drew
    Participant

    Many thanks Tom, I genuinely appreciate the effort!

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.