[Resolved] Excerpts set to 40 words display far more and masonry has big spaces

Please login to receive premium support.

Support for the free plugin can be found here.

Home Forums Pro Support Excerpts set to 40 words display far more and masonry has big spaces

Tagged: ,

This topic contains 12 replies, has 2 voices, and was last updated by  Tom 2 years, 6 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1344

    Tony
    Participant

    Hi Tom,

    Just bought the developer version of WP Show Posts Pro and ran into a couple of difficulties.

    If I set the except length to anything, say 40 words, I get all sorts of different length excerpts – ranging from 39 words to 188 words. Also, the masonry setting puts large white spaces between the tops and bottoms of posts.

    You can see it at: http://tonyrockliff.com/show-posts/

    Oh, and Happy New Year!

    Tony

    #1345

    Tom
    Keymaster

    Hi Tony,

    Are you using the “More tag” on any of those posts?: https://docs.generatepress.com/article/using-the-more-tag/

    If so, it will display your excerpt using the more tag instead of the 40 word setting.

    As for the masonry issue, can you try adding the shortcode outside of Beaver Builder in a regular page to see if the issue persists?

    Happy New Year!

    #1346

    Tony
    Participant

    Hi Tom,

    Thanks! I checked the post that is showing almost 200 words and there is no More tag being used.

    I put the posts page in a straight WP page at http://tonyrockliff.com/show-tests2/ and it didn’t change.

    Regards,

    Tony

    #1347

    Tom
    Keymaster

    Do those posts have a manual excerpt set in the “Excerpt” meta box? There’s only a couple reasons why the excerpt length would be ignored like that.

    Can you try deactivating all of your other plugins to see if the masonry thing is a plugin conflict?

    #1349

    Tony
    Participant

    Hi Tom,

    One down, one to go 🙂

    If you mean the Excerpt box in the drop-down at the top of the WP page, no, that isn’t checked.

    I deactivated all the plugins and the masonry problem was fixed, but the excerpts were still random.

    I re-activated the plugins one-by-one and the clash is with the WP-Rocket cache.

    Regards,

    Tony

    #1350

    Tom
    Keymaster

    Any chance you could send me temporary admin login details so I can take a look at the excerpts?: https://wpshowposts.com/contact/

    Hmm, I wonder what WP-Rocket was having issues was, I wasn’t noticing any JS errors. Did you try removing any JS minifying options that were set?

    #1352

    Tony
    Participant

    Hi Tom,

    I sent you the login details.

    I just tried unchecking JS Minify and Inline JS Minify – no difference.

    Regards,

    Tony

    #1353

    Tom
    Keymaster

    Ah, it’s the custom excerpt.

    In “Screen Options” at the top right, check the box next to “Excerpt”.

    Then scroll down and you’ll see those posts have custom excerpts set which is telling WPSP to ignore the 40 word limit.

    It looks like you have SiteGround caching and WP Rocket installed – it would be best to choose one and stick with it over having multiple ones.

    Not sure why WP Rocket is causing issues with masonry – the script is initiating, but isn’t calculating correctly. WPSP is using the bundled WordPress masonry script, so it’s very strange that it isn’t working.

    #1359

    Tony
    Participant

    Thanks Tom, yes. it was indeed the custom excerpts!

    Re using WP Rocket and SiteGround’s Supercacher at the same time, originally I thought the same as you, but both WP Rocket and SiteGround told me of their partnership – https://www.siteground.com/blog/wp-rocket/ – and that they are optimized to work best together. WP Rocket ran some tests at my site and confirmed that I got the best results running them in tandem.

    regards,

    Tony

    • This reply was modified 2 years, 6 months ago by  Tony.
    • This reply was modified 2 years, 6 months ago by  Tony.
    #1362

    Tony
    Participant

    Yay! I found the solution in one of the GeneratePress forum posts – turn off Lazyload for the blog page and masonry works great again. 🙂

    Regards,

    Tony

    #1367

    Tom
    Keymaster

    Aha, should have remembered that! Glad it’s all working now 🙂

    #1368

    Tony
    Participant

    Yes, great plugin! 🙂

    #1369

    Tom
    Keymaster

    Glad you like it! 🙂

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.