We're merging with GenerateBlocks! Learn more here.

[Resolved] list pagination issue

Please login to receive premium support.

Support for the free plugin can be found here.

Home Forums Pro Support list pagination issue

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
  • #957

    … another one:

    when using pagination for posts list, selecting a certain number of posts to show at once, there is always one post doubled – either with or without ajax pagination… and of course always one is missing.

    sorting is ‘random’ (which is demanded) – are there any issues with this combination?? other kind of sorting seems to work …


    Just so I can test:

    1. Set 5 posts to display
    2. Set the order to rand
    3. Enable pagination – ajax or not.

    Doing this will cause double posts?

    Let me know 🙂


    sorry… no matter how many posts set to display, there are always some doubled/some missing.
    loading more once – its one
    loeding more twice – theres two

    only when order is random!



    Thanks for letting me know – I’m on it 🙂


    Looked into this and found a solution – sort of.

    The best I can do for now is this:

    1. You enable pagination
    2. You set the order to Random

    This will display your posts randomly, and allow pagination to work without duplicating posts.

    However, your posts won’t randomize every time you reload now until the PHP session expires and is reloaded.

    So the random ordering works on the first load, and then that order is saved.

    Not perfect, but I figure it’s better than duplicating posts until a better solution is found.


    o.k. – but that doesn’t sound quite different than before… 🙂

    (not on working enviroment right now, will test again as soon if)

    did before:
    – select number of posts to show
    – set pagination (ajax or not)
    – set order to random

    … and got doubled posts.

    what is the difference now? setting number of posts, choosing ajax? sorry for maybe being slow on brains, but right now its not very clear to me what exactly makes the difference when so far nothing has changed??
    what did you experience while testing?
    the only way i got no doubled post with random ordering till now was setting to show all posts at once… no big deal until now with 12 or 13 posts, but as the number will grow this might be an issue regarding loading times…

    will try again (maybe tomorrow) anyway and see what happens. 🙂
    big thanks again so far – by far best and fastest support i’ve ever experienced on things like this!!


    The difference is that when you do that now, you won’t get double posts.

    However, your posts won’t randomize every time you reload the page – they will just appear in random order on the first reload, and will stick to that random order.

    Not ideal, but at least the double posts won’t be there while I search for a better alternative.


    … 🙂

    as already assumed theres is no change – sorry. or maybe still got something wrong …
    but always getting double posts when selecting ‘random’ as ordering together with pagination. no matter what i try.

    meanwhile thought this might interfere with other content on page, but its not the case when selecting other sorting than random.
    so issue still unsolved for me, will leave the sorting to something different for the time being.

    (btw: it came to my mind that there was another case like that with another theme but same demands and havent been solved till yet: cpts list, random sorting, pagination …)

    but maybe you want to take a look by yourself if youve got the time and motivation?


    Well, I haven’t released the update yet 😉

    Will at least get it uploaded to GitHub today 🙂


    … i knew there must be something missing! (but thought it might be on my side…) 😮


    Didn’t get it up on GitHub today, but will tomorrow 🙂


    … any news to this case?


    Just uploaded the change to GitHub.


    confirmed as resolved – no duplicate posts encountered with this fix!

    great job as always – thanks!


    Thanks for pointing it out!

    Only issue now is the posts don’t reload random now when you refresh – they stick to their original randomness.

    I’ll keep looking for a fix 🙂

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.