[Resolved] Post order

Please login to receive premium support.

Support for the free plugin can be found here.

Home Forums Pro Support Post order

This topic contains 9 replies, has 3 voices, and was last updated by  Tom 2 weeks, 6 days ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #10060

    paul
    Participant

    Hi,

    I have entered some manual post ids to display and would like them to display in the order in which they entered, however it seems that the ascending\descending field is overriding this manual ordering. Is there a workaround or fix available for this? Thanks

    #10066

    Tom
    Keymaster

    What if you set “Order by” to “No order”?

    Let me know 🙂

    #10068

    paul
    Participant

    sorry didn’t see that option! Thanks

    #10079

    Tom
    Keymaster

    No problem! Glad I could help 🙂

    #10423

    paul
    Participant

    Hi Tom – sorry to reopen this, I didn’t test this at the time just assumed it would work. I have set “order by” to “no order” and this has not worked. I wonder is the “order” field overriding this as there is only the option for ascending or descending?

    I am on latest beta version BTW

    • This reply was modified 2 months, 3 weeks ago by  paul.
    #10495

    Tom
    Keymaster

    What if you do this in your shortcode?:

    [wp_show_posts id="10" settings="orderby=post__in"]

    Be sure to update 10 with the actual ID.

    #11214

    David
    Participant

    I’m trying to order child pages using the Order number assigned to the page (so the list reflects the order I put them in the menu). I use Page Categories to select the pages I want. The list ordering is set to No Order, and I tried the settings="orderby=post__in" option Tom gave above. The list still doesn’t appear in the order I specify. Could “Page Order” be an available option in the List settings tab?

    #11246

    Tom
    Keymaster

    Hi there,

    What if you use menu_order instead of post__in?

    #11253

    David
    Participant

    That worked! Thanks, Tom!

    #11271

    Tom
    Keymaster

    You’re welcome 🙂

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.