[Resolved] Posts not in correct order!

Please login to receive premium support.

Support for the free plugin can be found here.

Home Forums Pro Support Posts not in correct order!

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #34563
    David
    Participant

    Hi everyone,

    I just added a fresh post to a site, and have the most recent 4 on the home page via WP Show Posts

    But the most recent post is showing second!
    Can’t work out why.
    I have checked the dates, and even changed the date of the new one to be today (was yesterday), but no change…
    The settings are correct in the WP Show Posts More Settings for date and order

    TIA, Dave

    https://powerhousepartners.com.au/

    #34604
    elvin
    Moderator

    Hi David,

    Can you share the current settings on “More tab” for the WPSP list in question. Also, can you share the exact shortcode used to display it?

    #34609
    David
    Participant

    Thanks Elvin,

    In More Settings, there is just:
    Order – Decending
    Order By – Date

    Status – Published
    Tax Operator – IN
    Add Basic Microdata is ticked
    All other fields are blank

    The shortcode is the one generated with no additional parameters
    [wp_show_posts id=”4754″]

    Dave

    #34611
    elvin
    Moderator

    Can you try disabling ALL plugins except WPSP + WPSP pro and see if it still occurs?

    Also, if you have a child theme, can you temporary deactivate it and check as well? (incase there’s a pre_get_post filter or any snippet that may mess with WP_Query)

    #34613
    David
    Participant

    Thanks Will do!
    Dave

    #34636
    elvin
    Moderator

    Let us know how it goes. 😀

    #34695
    David
    Participant

    Hi Elvin,
    I cloned the site to another location so I could test things without affecting the live site.
    I deactivated all the plugins other than GP/GB
    I turned off the child theme.
    But the problem still persists after that!

    This is the temp location to test:
    https://pemberton.info/play/

    There is a development page:
    https://pemberton.info/play/develop/
    And I added the core latest posts block and it displays them in the correct order

    If you need login info, let me know

    Dave

    #34702
    elvin
    Moderator

    Strange.

    Can you send the site credentials through our contact page to check? https://wpshowposts.com/contact/

    #34704
    David
    Participant

    Sure will do shortly!
    Dave

    #34710
    elvin
    Moderator

    Thanks.

    I’ve checked the posts and one of them is set to “Sticky”.

    Posts that are marked “sticky” are placed on the top of the list, completely bypassing the orderby.

    If you wish to ignore sticky status of posts and completely honor the orderby setting, you can set a WPSP list to ignore it.

    You can set the WPSP to “Ignore sticky posts” by checking its checkbox on More settings tab as shown here – https://share.getcloudapp.com/Z4urJy7k. 😀

    • This reply was modified 1 day, 1 hour ago by elvin.
    #34713
    David
    Participant

    Darn, sorry about that, I have never used sticky – it must have been accidently ticked!
    Apologies and thanks for working that out!

    Dave

    #34715
    elvin
    Moderator

    No problem. 😀

    #34723
    David
    Participant

    Resolved!

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.