We're merging with GenerateBlocks! Learn more here.

[Support request] Show Posts Images Not Working

Please login to receive premium support.

Support for the free plugin can be found here.

Home Forums Pro Support Show Posts Images Not Working

  • This topic has 20 replies, 2 voices, and was last updated 4 years ago by Tom.
Viewing 6 posts - 16 through 21 (of 21 total)
  • Author
  • #8369

    Some of the pages that I use showposts on require images to be a different size. So while I could lock some of them to be 400 pixels wide, that wouldn’t work for those pages that require a different size.


    Ah yes, that’s a change we’ll need to make in the plugin.

    I’ve made it here for WPSP 1.2, so you can make this change in your files if you’d like: https://github.com/tomusborne/wp-show-posts/commit/02f0cf276ae35eb6f35545a69322da447793658c

    Then you can do this:

    add_filter( 'wpsp_default_image_size', function( $size, $settings ) {
        if ( 123 === $settings['list_id'] ) {
            return 'your-size-name';
        return $size;
    }, 10, 2 );

    You’d just need to update 123 to the ID of your list.


    That could work .. definitely adds some complexity to the process of creating new show posts though. If you have a projected time in mind that doesn’t require adding an update to the functions.php for each show post let me know. I can use this solution for some of the critical pages though. For right now, it’s easier to force a column size and let the image resize with css.

    E.g. https://www.sandandsteelfitness.com/newsletter-subscribe-successful/

    Although that does waste bandwidth and hurts page speed.



    Deprecating the old image resizer will be difficult, so I don’t have an accurate timeframe at the moment. It’s high up on my list of things to do in the plugin, though.


    I understand… I’m sure you will get it in due time. You have a good track record for that kind of thing. Thanks for all your help.


    No problem! 🙂

Viewing 6 posts - 16 through 21 (of 21 total)
  • You must be logged in to reply to this topic.