[Resolved] Social Icons Not Showing WP Show Posts Pro

Please login to receive premium support.

Support for the free plugin can be found here.

Home Forums Pro Support Social Icons Not Showing WP Show Posts Pro

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #24952
    Michelle
    Participant

    I used short code from WP Show Posts Pro on a page to display my posts, but the social icons do not show. I’d like to have them on the site.

    Any solutions are appreciated.

    #24974
    elvin
    Moderator

    Hi,

    You’ll have to tick “Show social sharing buttons” and the social media icons you want to display for them to show on the list.
    https://share.getcloudapp.com/z8u4BgDd

    #24987
    Michelle
    Participant

    The box for “Show Social Sharing Buttons” is ticked, and I have the social media icon settings filled in with my urls.

    Just like the issue with two short codes not displaying on the same page, once I deselected the Posts Page designation in Settings>Reading, the social sharing buttons displayed. I really don’t know what’s going on, but my guess is that we made a lot of CSS changes to WP Show Posts on the blog page, so maybe the CSS is overriding my WP Show Posts Pro settings. Maybe?

    These are the CSS additions:

    /*Blog Page Meta Styling*/
    .wp-show-posts-inner .author-name:before{content:’by ‘; color: #000000;}
    time.wp-show-posts-entry-date.published {
    color: black;
    }
    .wp-show-posts-terms .wp-show-posts-meta{color: #b80000;}

    /*Single Post and Archive Page Meta Styling*/
    time.entry-date.published{
    color: black; padding: 0 5px 0 5px;
    border-right: 1px solid black;
    border-left: 1px solid black;
    }
    .cat-links a{
    color: #b80000;
    }
    .author-name{color: #b80000;}

    #24989
    Michelle
    Participant

    I just discovered that I don’t have social icons on single post pages either.

    #25043
    elvin
    Moderator

    Just like the issue with two short codes not displaying on the same page, once I deselected the Posts Page designation in Settings>Reading, the social sharing buttons displayed. I really donโ€™t know whatโ€™s going on, but my guess is that we made a lot of CSS changes to WP Show Posts on the blog page, so maybe the CSS is overriding my WP Show Posts Pro settings. Maybe?

    Please check my answer related to this here. ๐Ÿ™‚
    https://wpshowposts.com/support/topic/two-short-codes-on-a-page-only-one-displays/#post-25041

    I just discovered that I donโ€™t have social icons on single post pages either.

    WP Show Posts doesn’t add in social icons on single posts pages.

    WP Show posts only shows a list of posts.

    Adding something to single posts pages is something you do with a social media plugins and/or theme settings, hooks and filters. ๐Ÿ™‚

    #25048
    Michelle
    Participant

    Gotcha. Ok. Thank you.

    #25050
    elvin
    Moderator

    No problem. ๐Ÿ˜€

    If you need help with adding social media icons on your single post pages, you can search the GeneratePress support forums.

    I believe that particular question has been asked a lot there. You should be able to find clues.

    You can also open up a new topic if you require something specific. ๐Ÿ™‚

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.