We're merging with GenerateBlocks! Learn more here.

[Support request] Unable to display show posts content

Please login to receive premium support.

Support for the free plugin can be found here.

Home Forums Pro Support Unable to display show posts content

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #1319

    Hi Tom

    Just purchased WPSP Pro and trying to set up posts page.

    Firstly theme is fairly old and was created in Artisteer. need to migrate to GP Pro at some point but that’s a whole new ballgame!

    I already have a Blog Page and have previously set that as my Posts page http://www.marshallpersonaltraining.co.uk/blog/
    Created my first WPSP Post List, bog standard, no Pro features enabled yet until I’ve got it working as my blog page.

    To add shortcode I had to change the default posts page in “Settings, Reading” then go into the Blog Page, add the shortcode then go back into Settings, Reading and change it back to the original Blog page.

    However when I now view the Blog page it just shows the original blog format and not the Show posts format.

    I did create a page as per the tutorial video and whilst that shows the WPSP posts in the desired format as soon as I change it to be the default posts page it still only displays the original post format. http://www.marshallpersonaltraining.co.uk/blog-posts/

    Ideally I’d like to use the Show Posts format but of course on the original Blog page as this has been indexed, etc etc.

    Hopefully I missed something that easily rectifies this….fingers crossed!

    Thanks Tom


    Hi Nigel,

    Setting a page as the posts page tells WordPress to ignore everything inside the content editor – so that won’t work.

    Instead, you would simply leave the posts page option empty in Settings > General, and place the WPSP shortcode on a static page which has the same URL as the old blog.

    Let me know if you need more info 🙂

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.