Black Friday sale! Get 25% off WPSP Pro! Discount automatically applied at checkout.

[Resolved] WP Show Post doesn't show the images

Please login to receive premium support.

Support for the free plugin can be found here.

Home Forums Pro Support WP Show Post doesn't show the images

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #5531
    palomikis
    Participant

    Hello,

    I have just got WP Show Pro. I have create a list following mostly the example on your video but I had some problems:

    1. The images doesn’t appear. I really don’t know why. I have tried creating three different lists, changing width (200px or 300px or leaving it blank), or changing number of columns as it could be a problem of images seize, or changing the options to display the images above the title o behind de title… but nop. Still doesn’t appear.
    2. Also, if a mark an except and 30 words, it gets the whole text. If I mark complete, it also gets the whole text. I guess it is because I use the -read more- tag and don’t have active the excerpt option on wordpress… is there any way to make it appear just 30 words without using the wordpress excerpt?

    Anyway, the most important problem is number 1, the non-displaying images. Can you help me?

    #5534
    Tom
    Keymaster

    Hi there,

    1. That’s very strange – the HTML for image isn’t even showing up. You’re sure you have the checkbox checked to display images? If so, is there any way you can send me temporary admin login details so I can take a look?: https://wpshowposts.com/contact

    2. So you have it set to show the excerpt, but it’s showing the entire post? Is this happening on a specific page?

    #5536
    palomikis
    Participant

    Hi! I have just checked and now the images appear but only two of them… Could it have been because of a bad connectivity? Also, you can see in the same link I sent you the issue about the excerpt. .-)

    Anyway, I will send you a temporary login in a few minutes.

    Thanks!!!

    #5547
    Tom
    Keymaster

    So what’s happening is the images are only displaying because they’re within your content, and the full content is showing for those posts.

    The posts without an image are showing the excerpt (which strips HTML, like images).

    So the solution:

    1. Set your images as “Featured Images”.

    2a. Remove the more tag from your posts so the excerpts show.
    2b. Use the custom excerpt metabox provided by WordPress to add a custom excerpt.

    I think those are the only two options to fix #2 (and #1).

    Let me know if this makes sense or not 🙂

    #5554
    palomikis
    Participant

    Yes, it makes sense! I will try this.
    Thank you!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.