Support Forum

Please login to receive premium support.

Support for the free plugin can be found here.

Forum Replies Created

Viewing 15 posts - 16 through 30 (of 31 total)
  • Author
    Posts
  • in reply to: polaroid reduce image and enlarge content-wrap #23772
    Carlo
    Participant

    Thank you Elvin, It works.

    in reply to: add svg icons over the image #23637
    Carlo
    Participant

    Hi David,

    the link is missing πŸ™‚

    Anyway, I got it. I was going crazy because it was not working but then I found out that… wordpress had not get the icon I put in the custom field’s post. Updating the post again did the trick πŸ˜€

    About the css, I have added a class to the icon and stylized it this way:

                                position: absolute;
                                bottom: 230px;
                                width: 60px;

    The hook is wpsp_before_title.
    The aim is to have the icon over the image (basic card style) in the top area.

    Is it ( “wpsp_before_title” hook in combination with the css I showed you above) a good approach or would you suggest something better?

    in reply to: add border but not around images #23516
    Carlo
    Participant

    Never mind, solved πŸ™‚

    In case it could be useful for someone else:

    .wpsp-content-wrap {
                             
                                border-color:aqua;
                                border-style: solid;
                                border-width: 1px;
                            }
    in reply to: how to fix wpshowpost tag element flashing #22488
    Carlo
    Participant

    I am sorry Tom, I am not sure I understand right: Do you mean you see it on the top now?
    It’s because I had to set the “old” “wrong” css as I said in the note above since I can’t keep the tag in that position for long in the homepage.

    Is there any way you could please check with the inspector? If not, I’ll do a new list in a page apart.

    Thanks.

    in reply to: how to fix wpshowpost tag element flashing #22449
    Carlo
    Participant

    Hi Tom,

    about the point 1)
    Now the flashing is fixed but the tag is not in the desiderd position anymore (it’s now vertically floating in the middle).
    How can I have it in the same previous position (on top, align to the top border)?

    Note: I had to go back to the previous “wrong” css in order to keep the tag in the right position while waiting for your kind reply πŸ™‚

    Point 2)
    Done, thanks
    Is there a way to be kept updated about when it will be fixed?

    in reply to: cards of same height in carousel #22202
    Carlo
    Participant

    Thank you Tom, it worked.

    If I may ask, how to make the dots below the cards bigger?

    Carlo
    Participant

    Never mind, it seems to work now.
    I am still testing but I think it was wp rocket and then asset cleanup πŸ˜€

    Thank you guys.

    Carlo
    Participant

    Hi Michal,

    would you like to share your steps?

    Did you install the “extra” plugin? (https://docs.wp-rocket.me/article/976-exclude-files-from-defer-js)
    If yes, what was the edited code?

    What are the options activated in wprocket settings?

    Thank you πŸ™‚

    Carlo
    Participant

    I also excluded the same path from concatenation in wprockets options.
    I am not sure if something has changed (not visible yet).

    When reloading the page, the carousel appears for less than a second and then disappear.

    Carlo
    Participant

    I tried this today (is still implemented) but no success. Could you please check?

    The code in their php file is now (after my editing of $excluded_files[] row):

    <?php
    /**
     * Plugin Name: WP Rocket | Exclude Files from Defer JS
     * Description: Exclude files from defer JS option.
     * Plugin URI:  https://github.com/wp-media/wp-rocket-helpers/tree/master/static/wp-rocket-static-exclude-defer-js/
     * Author:      WP Rocket Support Team
     * Author URI:  http://wp-rocket.me/
     * License:     GNU General Public License v2 or later
     * License URI: http://www.gnu.org/licenses/gpl-2.0.html
     *
     * Copyright SAS WP MEDIA 2018
     */
    
    namespace WP_Rocket\Helpers\static_files\exclude\defer_js;
    
    // Standard plugin security, keep this line in place.
    defined( 'ABSPATH' ) or die();
    
    /**
     * Exclude scripts from WP Rocket’s defer JS option.
     *
     * @author Caspar HΓΌbinger
     * @param  array  $excluded_files   Array of script URLs to be excluded
     * @return array                    Extended array script URLs to be excluded
     */
    function exclude_files( $excluded_files = array() ) {
    
    	/**
    	 * EDIT THIS:
    	 * Edit below line as needed to exclude files.
    	 * To exclude mupltiple files, copy the entire line into a new line for each file you wish you exclude.
    	 */
    	$excluded_files[] = '/wp-content/plugins/wp-show-posts-pro/modules/carousel/slick/slick.min.js';
    	// STOP EDITING
    
    	return $excluded_files;
    }
    add_filter( 'rocket_exclude_defer_js', __NAMESPACE__ . '\exclude_files' );
    
    Carlo
    Participant

    Is it possible to exclude certain scripts from being deferred?

    Hi Tom,
    I guess so, I found this:
    https://docs.wp-rocket.me/article/976-exclude-files-from-defer-js

    Could you tell me what are the script paths to exclude?

    Thank you. Carlo

    Carlo
    Participant

    update: it does not work on PCs either.

    Waiting forward for your support. Thank you. Carlo

    Carlo
    Participant

    Sorry, a word is missing, I meant:
    If I switch OFF mobile caching in wp rocket, the carousel works.

    in reply to: Carousel animation #20319
    Carlo
    Participant

    1) yes it was activated.

    I found the problem and fixed it:
    for everyone else should have the same issue:

    Copying and pasting the code above, I did not noticed that the quotes were wrong for my system:
    β€˜ instead of '

    Replacing them with the correct ones fixed it.

    Here’s my code

    add_filter( 'wpsp_carousel_args', function( $args, $settings ) {
    if ( 160757 === (int) $settings['list_id'] ) {
    $args['autoplay'] = true;
    $args['autoplaySpeed'] = 3000;
    }
    return $args;
    }, 10, 2 );

    With 160757 to be replaced with the list id of the right list.

    Thank you elvin. πŸ˜‰

    in reply to: Carousel animation #20197
    Carlo
    Participant

    Hi elvin,

    thank you for your support.

    Yes, autoplay is what I am looking for. πŸ™‚

    1) Where should I put the code of the filter you mentionted?
    – Generally in functions.php?
    I have tried creating a snippet with code snippets, put a carousel in a page and tested, but the carousel seems to be stuck on the first card.

    2) Are there any parameters I can use?
    – seconds between one card to another
    – define which carousel is in autoplay

    Thank you again!

Viewing 15 posts - 16 through 30 (of 31 total)